shop-wiz logo
Follow Us on Facebook Follow Us on Google+ Follow Us on Twitter Follow Us on LinkedIn
제목 인스톨문제...
등록일 2011.02.20 HIT 7784 작성자 학도
인스톨 중에 이런 문제에 봉착했습니다.

Error : Incorrect integer value: '' for column 'UID' at row 1
OutPut Message : INSERT INTO `wizCategory` VALUES ('', '1', 'wizavatar', 010, '패션샵', NULL, NULL, NULL, NULL, NULL, NULL, '');

이 문제를 어떻게 해결할 수 있을까요..

억지를 써서 또 다시 실행했습니다.

이번엔

Error : Incorrect string value: 'xEDx8CxA8xECx85x98...' for column 'cat_name' at row 1
OutPut Message : INSERT INTO `wizCategory` VALUES ('1', '1', 'wizavatar', 010, '패션샵', NULL, NULL, NULL, NULL, NULL, NULL, '');

이것은 또 어떻게 해결을 해야 할까요??

실력이 모자라 소스를 봐도 잘 모르겠습니다. 

한 가지 문제가 더 있는데 소스를 보면 
이 INSERT를 시도하기 전에 
INSERT INTO ".$WIZTABLE["MAIN"]." VALUES ('', '', '', '','$admin', '$PASS', 'A', '', '$Wdate')
와 
INSERT INTO wizTable_Grp VALUES ('', 'root', '', '', '','일반게시판', '1', $Wdate)
를 먼저 시도하는데 데이터베이스를 보면 테이블은 7개가 만들어져 있는데
이 두개의 INSERT가 실행이 되지 않은 상태입니다. 

이것은 또 왜 일까요??
휴... 답변 부탁드립니다. 

아 그리고 문제의 소스는 wizmallmalladmininstallinstall3.php 입니다.

댓글보기
폰돌 mysql 옵션이 엄격하게 적용된 것 같네요
Error : Incorrect integer value: '' for column 'UID' at row 1
OutPut Message : INSERT INTO `wizCategory` VALUES ('', '1', 'wizavatar', 010, '패션샵', NULL, NULL, NULL, NULL, NULL, NULL, ''); 
상기 명령은 기본적인 mysql 이라면 문제없이 들어갑니다. 그러나 현재 님의 개발 환경이 정확하게 어떤지 모르겠으나 현재 메시지는 UID 필드가 원래 integer type이 들어가야 하는데 ''라는 String 타입으로 들어가서 발생하는 에러입니다.
부분 부분적으로는 아래와 같이 엄격하게 문법을 적용하여 고치면 되겠으나 제 프로그래 전반적으로 많은 부분이 이렇게 적용되어 있으므로 원천적으로 mysql 및 php의 환경을 고치시는 것이 더 나을 듯합니다.
수동으로 고치는예
$sqlstr = "INSERT INTO `wizCategory` (cat_order, cat_flag, cat_no, cat_name, cat_price, cat_skin, cat_skin_viewer, cat_top, cat_bottom, cat_img, pcnt )VALUES ('1', 'wizavatar', 010, '패션샵', NULL, NULL, NULL, NULL, NULL, NULL, 0);" 처럼 이후 라인에도 수정하시면 됩니다. 즉 앞단에 필드명을 모두 열거하고 대신 UID 쪽 필드는 제외한 예입니다.

이런식의 예로 보시면 다른 파트도 어떻게 처리하실 지 아실 것 같습니다. 필드명을 하시고 필드타입이 integer 인것은 value 에 0 혹은 다른 숫자를 넣어시고..


여하튼 다음 배포할때는 이부분에 대해서도 주의를 하도록 하겠습니다. 여지껏 저의 테스트 환경에서는 에러가 발생하지 않아서 비표준적(?)인 문법을 따랐던 것 같습니다.
2011.03.11 X
김갑판 폰돌님 테스트환경은 어떤환경인지좀 가르쳐주세요 저는 오토셋으로 돌려봣어용 ㅠ 그니까 위에랑 똑같은 에러가뜨네요 2011.08.14 X

Powered by shop-wiz since 2002, e-mail:wangta69@naver.com